Stern Avengers 2020

Wayne J

Registered
Jul 22, 2011
1,481
1,691
113
47
Walsall
Alias
WWJ
Battle royal is a lot of fun and challenging !


Sent from my iPhone using Tapatalk Pro
Have played it twice, once from the shortcut, once getting there properly.
Completed it both times, although no idea what's going on😲 Both scores 193mil.
Score based on flips used, time taken and Avengers left.
 
  • Like
Reactions: Pick Holder

Gonzo

Site Supporter
Sep 2, 2019
1,338
1,651
113
Sandhurst
Alias
Kris
Have played it twice, once from the shortcut, once getting there properly.
Completed it both times, although no idea what's going on😲 Both scores 193mil.
Score based on flips used, time taken and Avengers left.

Shortcut?
 

Wayne J

Registered
Jul 22, 2011
1,481
1,691
113
47
Walsall
Alias
WWJ
Shortcut?
Press and hold flipper buttons before starting a game. This brings up options. Standard play, Competition play (all randomness removed) & Battle Royale.

Alternatively you can go in to game menu and set it so that it starts Battle Royale every time
 
  • Love
Reactions: Gonzo

Gonzo

Site Supporter
Sep 2, 2019
1,338
1,651
113
Sandhurst
Alias
Kris
Press and hold flipper buttons before starting a game. This brings up options. Standard play, Competition play (all randomness removed) & Battle Royale.

Alternatively you can go in to game menu and set it so that it starts Battle Royale every time

Sneaky . . . . . cheers mate
 

J85M

Site Supporter
Feb 24, 2017
554
361
63
UK
Looks like Stern are issuing new subway mechs to all owners, regardless if your current subway has blown its welds or not.

Small design changes to the new one along with better welds.
 
  • Like
Reactions: Jazzbouche

Jazzbouche

Registered
Jan 10, 2017
249
164
43
Warwick
Awesome. It’s needed, and that’s decent enough customer service. Just gotta deal with the shipping time now, and probably a backlog of demand.
 

J85M

Site Supporter
Feb 24, 2017
554
361
63
UK
are electrocoin on this then Neil or do we each individually need to shout up to Phil and ask for one?
 

Gonzo

Site Supporter
Sep 2, 2019
1,338
1,651
113
Sandhurst
Alias
Kris
Press and hold flipper buttons before starting a game. This brings up options. Standard play, Competition play (all randomness removed) & Battle Royale.

Alternatively you can go in to game menu and set it so that it starts Battle Royale every time

Cheers for the info Wayne.

What a fantastic mode. Great fun to play and something I'd never reach during standard play.

Eventually I beat them although it was close and I had a bad start. Really good mode, fast and furious.

20201111_214324.jpg
 

J85M

Site Supporter
Feb 24, 2017
554
361
63
UK
So I lifted the Ant-Man guide to try and stop the pooling and avoid chipping, glad I did as it was probably going to get worse and currently it’s very minimal.

Placed the smallest washer I could find under the rail leg, sorry should have paid attention to what washer I used but basically the smallest that would fit on the rails leg, had to screw it on the leg by hand as the thread was tight.

Put everything back on (ramp after ramp after ramp lol) and then gently tightened the rail until it gripped the washer just enough and the guide wasn’t moving.

Chucked about 30 games on it since and it seems to be working perfectly, no interference with the ball and the rail is nicely off the playfield now, fingers crossed it’s done the job. Thought I would post this up Incase it comes in handy for anyone else.

FBBC1BF7-DFD1-47AC-A85C-32C5972B004D.jpeg3620AF8F-2E12-4012-9AF2-D74F1B7EC3BF.jpegACFBEDD8-B695-4011-96A4-FCC94E7CE41C.jpeg85504138-310E-41DF-AA8A-660A1154EE7E.jpeg
 
Last edited:

replicas

Site Supporter
Jul 21, 2011
10,764
5,085
113
Lancashire
Alias
Nipper Pinball
So I lifted the Ant-Man guide to try and stop the pooling and avoid chipping, glad I did as it was probably going to get worse and currently it’s very minimal.

Placed the smallest washer I could find under the rail leg, sorry should have paid attention to what washer I used but basically the smallest that would fit on the rails leg, had to screw it on the leg by hand as the thread was tight.

Put everything back on (ramp after ramp after ramp lol) and then gently tightened the rail until it gripped the washer just enough and the guide wasn’t moving.

Chucked about 30 games on it since and it seems to be working perfectly, no interference with the ball and the rail is nicely off the playfield now, fingers crossed it’s done the job. Thought I would post this up Incase it comes in handy for anyone else.

View attachment 124835View attachment 124836View attachment 124837View attachment 124838
Bally Williams always used washers on ball guides like the above. Seems like another Stern cost cutting exercise.
 

cyberkryten

Site Supporter
Jul 18, 2017
273
243
43
Wiltshire
Alias
Martyn
Aside from the subway mech, anyone having issues with:

a).ball getting lodged under pop bumper
b) shooter lane auto plunge hitting plastic on left and bouncing to get stuck under the glove

I‘ve had to take the glass off to free balls more on this game in the couple of weeks I’ve had it than all other games combined!!
 

Neil McRae

Site Supporter
Jun 5, 2016
10,505
7,354
113
Surrey
playpinball.uk
Alias
Neil McRae
Not on mine so far Martyn, I turned my subway off before it breaks anyway - I occasionally get the ball coming off the ramp on the plunge shot.
Couple of folks on pinside have had the balls stuck on the pops and a couple of other places and have put plastics/rubber bumpers in to stop it

Cone Shaped Clear Rubber Bumpers... https://www.amazon.co.uk/dp/B075KWVTJV?ref=ppx_pop_mob_ap_share

Sent from my iPhone using Tapatalk Pro
 

J85M

Site Supporter
Feb 24, 2017
554
361
63
UK
Aside from the subway mech, anyone having issues with:

a).ball getting lodged under pop bumper
b) shooter lane auto plunge hitting plastic on left and bouncing to get stuck under the glove

I‘ve had to take the glass off to free balls more on this game in the couple of weeks I’ve had it than all other games combined!!

Reduce the power on the auto plunger that will solve b for you.
 

cyberkryten

Site Supporter
Jul 18, 2017
273
243
43
Wiltshire
Alias
Martyn
Reduce the power on the auto plunger that will solve b for you.

I don't think that's it. It looks like the lane guide on the right has deformed/come away from the edge. I've tried to highlight it in this pic, instead of being tight to the right hand side like the sections above and below, you can see a gap and the metal has bowed away from the edge. This then forces the ball to the left as it exits, hitting the Mjolnir plastic near the screw at the top of the pic and bouncing up from that, instead of allowing it to head straight up to the orbit.

Guide away from edge.jpg

Ball lodged under Gauntlet.jpg
 

J85M

Site Supporter
Feb 24, 2017
554
361
63
UK
I don't think that's it. It looks like the lane guide on the right has deformed/come away from the edge. I've tried to highlight it in this pic, instead of being tight to the right hand side like the sections above and below, you can see a gap and the metal has bowed away from the edge. This then forces the ball to the left as it exits, hitting the Mjolnir plastic near the screw at the top of the pic and bouncing up from that, instead of allowing it to head straight up to the orbit.

View attachment 124952

View attachment 124953
Pretty sure mines the same, have you tried turning the auto plunger power down? It worked for a load of guys over on pinside.
 

Neil McRae

Site Supporter
Jun 5, 2016
10,505
7,354
113
Surrey
playpinball.uk
Alias
Neil McRae
Martyn check pinside the guy had the same problem and found a place to stick it. Your shooter lane looks same as mine.

Got this today




Sent from my iPhone using Tapatalk Pro
 

Wayne J

Registered
Jul 22, 2011
1,481
1,691
113
47
Walsall
Alias
WWJ
Not had the ball stuck in the pops or issues with the right orbit/ramp - but have been having the ball bounce over the up-post which holds the ball at the start of modes (on a Pro).
Can't see anyway that any mod can solve the issue?

I'm also finding that starting a gem quest, with at least one portal lock, followed by a MB (Thor or IM ) are the way for big scores as add a balls are so easy to get, every MB turns into a 6 ball
 

Jazzbouche

Registered
Jan 10, 2017
249
164
43
Warwick
Another day another issue.
So my flippers seem to be randomly firing off other switches. Specifically the inner loop (captain marvel loop). It’s a nice way to get a good score, but not much fun. In the switch tests it’s sporadic, but shows the issue, and occasionally I get a glimmer of it triggering the 3 bank targets too. Is this a switch issue, or node board, or something else? Any ideas?
I’m not sure if I’ve had a session on this yet without taking the glass off.
Cheers.

Actually the inner loop is the ‘inner loop’ not a ramp.
 
Last edited:

Neil McRae

Site Supporter
Jun 5, 2016
10,505
7,354
113
Surrey
playpinball.uk
Alias
Neil McRae
hmm, I'd guess a node board, I'd reseat the ethernet cables between the boards. see if there is any commonality between the items triggering and the flippers and the bottom board.