What's new
Pinball info

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

First Pin project. Mr & Mrs Pacman

OP
itsmecurrie

itsmecurrie

Registered
Joined
Dec 5, 2019
Messages
57
Location
Belfast
Still getting 6v a/c on TP4 so has to be somewhere else on the machine. Balls
e54415ed98e5a2f64dbe74399eaf9d96.jpg


Sent from my LE2113 using Tapatalk
 

Telboy

Registered
Joined
Feb 6, 2017
Messages
57
Location
Loughborough
There's an AUX driver board under the play field that controls the GI if I remember correctly
That controls the GI lighting
47977c4f094b779f84b75ffa7d2d4c09.jpg



Sent from my iPad using Tapatalk
 
OP
itsmecurrie

itsmecurrie

Registered
Joined
Dec 5, 2019
Messages
57
Location
Belfast
Check the pins for dry joints
I'm casting my mind back as to stupid things I've done that could have caused the GI to stop working. The biggest culprit... Accidentally touching an alan key between a flipper switch and the metal housing of the score board under the maze. Sparked and I assume blew something. I've checked fuses but all seems fine.



Sent from my LE2113 using Tapatalk
 

astyy

Play Flipper Games for Fun and Recreation
Joined
Jan 19, 2015
Messages
2,921
Location
Basingstoke
Normally a dedicated bulb for the GI flasher (and Solenoid Expander) nearby to check too :thumbs:
 

Paul

Staff member
Joined
Oct 5, 2012
Messages
9,823
Location
South Wales
U1 is an optoisolator. My bet is Q1 (Tho i know nothing about these, and for the cost if it's suspect i'd just replace both)
 
OP
itsmecurrie

itsmecurrie

Registered
Joined
Dec 5, 2019
Messages
57
Location
Belfast
you won’t get a continuity beep across that,try measuring its resistance instead.

your problem is probably a loose connection or bad header pin. .
I fear more so something has blown/fried. I accidentally touched an alan key between a flipper switch and the under playfield scoreboard metal housing. Sparked and GI went on vacation idiot

Sent from my LE2113 using Tapatalk
 

astyy

Play Flipper Games for Fun and Recreation
Joined
Jan 19, 2015
Messages
2,921
Location
Basingstoke
For the GI you likely have the GI Flasher PCB that has no Q1 (different to pic above) but connects to the Triac mounted on the power chassis. I have had U1 fail that took out the GI. In my case the machine had two GI Flashers (one for pf, one for bb) and I swapped them over to troubleshoot that the issue was on the GI flasher.
 
OP
itsmecurrie

itsmecurrie

Registered
Joined
Dec 5, 2019
Messages
57
Location
Belfast
Folks. Is there an award for idiot of the year here on the forum? Load lamp beside the aux driver had blown. How did I not know about that back in business though. Thanks for all the advice, I just know you guys didn't mention that because it's such a school boy error not to check
3d0d97a6fb680eb0ecb743bb5c5aeead.jpg


Sent from my LE2113 using Tapatalk
 
Top Bottom