WOZ light help needed

GillAy

Registered
Sep 4, 2018
38
8
8
Glossop
The multi coloured lights on my WOZ keep flashing all the colours.
Looking this up it seems that the O light of the RAINBOW isn't working properly. It doesn't show white.
How do I go about fixing this? I can't see how to get at the led.
Thanks,
Gill
 

robertlucas1970

Site Supporter
Feb 29, 2016
913
740
93
Shrewsbury
I am not sure where this light is as its been a while since I had a WOZ , but you can turn lights off in the menu. If one light goes faulty it can effect the others, so by turning the one off which is faulty the others should be fine.
The bad news is I expect you will new light board, I did fix a few that went on one of mine, but was not easy.
 

PabloUK

Registered
Dec 24, 2018
75
40
18
North East England
IMO there is only one bullet proof option here is to purchase the 2.0 light kit upgrade. Once I started playing around with poor cable connections and trying to identify if its a board or a dodgy wire. Just take the plunge and buy the light kit you will never have another issue again. The single boards are £40 a pop I would really just upgrade.
 
  • Like
Reactions: Neonadz

robertlucas1970

Site Supporter
Feb 29, 2016
913
740
93
Shrewsbury
IMO there is only one bullet proof option here is to purchase the 2.0 light kit upgrade. Once I started playing around with poor cable connections and trying to identify if its a board or a dodgy wire. Just take the plunge and buy the light kit you will never have another issue again. The single boards are £40 a pop I would really just upgrade.

Does not sound cheap, but then again I had 3 big boards go and spent around £500 getting it working again which is why I spent so much time trying to see if I could repair these.
 
OP
G

GillAy

Registered
Sep 4, 2018
38
8
8
Glossop
Thx for swift replies.
O in RAINBOW doesn't show red or white so I turned W10 board off. Makes no difference. Maybe there's another problem too.
I have a light upgrade kit which came with the WOZ when I bought it, wsa hoping to get a few more plays before installing it but it looks like I have an extra job tomorrow.
 

AlanJ

Site Supporter
Dec 27, 2017
3,079
3,007
113
Leeds, West Yorkshire
Alias
I am me
just out of interest what’s the issue with the original woz lighting and what’s different in the v2.0 lighting upgrade?

did it affect any other jjp models?


Sent from my iPhone using Tapatalk
 

Spandangler

Site Supporter
Jul 21, 2011
5,586
3,639
113
Suffolk
In a nutshell they shipped initially with 5v boards which aren’t sufficient to handle the loads so they fail. It’s likely “when” not “if” they fail.
So they beefed them up to 7.5v but same issues so they fixed the problem with Hobbit and subsequently released a 2.0 lighting kit for WOZ which had to bought separately at a huge cost (mine was about £750-£800)

Badly designed initially but sorted now.
 
  • Like
Reactions: Neonadz and AlanJ

Colywobbles

Site Supporter
Nov 9, 2016
1,459
2,434
113
Sunderland
www.colspinballmods.com
Alias
Colin Chapman
All WOZ pins came with the early boards and I think only the last couple in got shipped with v2. Its a slippery slope once you start to repair them not to mention a pain in the ****. If your WOZ is a keeper just bite the bullet and get the v2 set from Phil. It’s a lot of work (around 3 days for a mere mortal like me) but in the end well worth it as it’s a thing of beauty.
you can start switching boards off to bypass the flickering and the likes but it kinda starts to lose the aforementioned beauty as lighting is one of the feature where this table excels Above all others IMO.
Since fitting v2 in mine it has been flawless.
 
  • Like
Reactions: Neonadz

Neonadz

Registered
Oct 21, 2017
191
61
28
Derbyshire
going to lift an old thread ....JJP have these in stock as of today ..just bought a 2.0 kit for my OZ
contact Ken Holland for the kits
 

Neonadz

Registered
Oct 21, 2017
191
61
28
Derbyshire
In a nutshell they shipped initially with 5v boards which aren’t sufficient to handle the loads so they fail. It’s likely “when” not “if” they fail.
So they beefed them up to 7.5v but same issues so they fixed the problem with Hobbit and subsequently released a 2.0 lighting kit for WOZ which had to bought separately at a huge cost (mine was about £750-£800)

Badly designed initially but sorted now.
just got my kit ...
 
  • Like
Reactions: Spandangler

Neonadz

Registered
Oct 21, 2017
191
61
28
Derbyshire
All WOZ pins came with the early boards and I think only the last couple in got shipped with v2. Its a slippery slope once you start to repair them not to mention a pain in the ****. If your WOZ is a keeper just bite the bullet and get the v2 set from Phil. It’s a lot of work (around 3 days for a mere mortal like me) but in the end well worth it as it’s a thing of beauty.
you can start switching boards off to bypass the flickering and the likes but it kinda starts to lose the aforementioned beauty as lighting is one of the feature where this table excels Ab

See the kit is sold out again !
hi Ken ...its listed as sold out but they are available ....mail ken holland and get on the list for the next run ...think they are making a bunch at a time while producing new pins
my order has been with them 12 weeks but now here
 

Kenny Taylor

Registered
Jul 27, 2015
2,105
674
113
North East of Scotland
Wiggled the cable on the two small faulty boards, right side anf under right slingshot, they now work, the rest on that daisy chain are no longer playing up too 👍
Hmm they are back playing up but not as bad as before and at least not causing the chain further up issues.. gonna need 2.0.
Does anyone that has done the 2.0 upgrade have two spare one LED 7.5v boards that work.

Unfortunately WOZ is my sons favourite game. So keen to get it right!
 

Neonadz

Registered
Oct 21, 2017
191
61
28
Derbyshire
the 2.0 kit is dimmer ...but it is what it is
i have some 12v spot lights coming to mount on the slings ,same as the factory ones that light the castle and munchkin land ,just think JJP didnt put enough light in the slings ,1 GI was never enough
 
  • Like
Reactions: Kenny Taylor

Kenny Taylor

Registered
Jul 27, 2015
2,105
674
113
North East of Scotland
Yeah I’d heard the 2.0 kit is dimmer :-(. The previous owner also fitted additional spot lights and a strip of leds at the top of the machine. I’ll definitely be ordering the 2.0 kit. How long did it take you to fit it?
 

Neonadz

Registered
Oct 21, 2017
191
61
28
Derbyshire
strange he had fitted them with the 7.5 running ,mine was bright enough while it was running
i had it fitted Kenny
forum member ,he has done 3 WOZ
took him a full day