Twilight Zone Providing two balls in the shooter lane

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Twilight Zone Providing two balls in the shooter lane
I've got an issue, when ball 1 is locked, two balls are thrown in the shooter lane.
This conitues to happen as long as ball 1 is locked. I've checked all the direct and potentially switches, the all work fine. When ball 1 is locked it is recognized and diesplayd Ball 1 locked. But then two balls are provied into the shooter lane. Also Powerball dedection works very well, I've got the 'PROXIMITY DETECTOR MODUL for TWILIGHT ZONE TROUGH SENSOR' board installed, which works very well.

Any clue/help is very appreciated.
Many thanks
Here is the list of switches that I checked and they all work fine

Switch# Description
84 Lock Center
85 Lock Upper
88 Lock Lower
15 Right Trough
16 Center Trough
17 Left Through
18 Outhole
25 Far Left Through
26 Through Proximity
 

CHRIS B PINBALLS

Site Supporter
Feb 11, 2019
1,288
2,075
113
bingley
Have you got the correct amount of balls in it
Maybe worth going in to the menu and removing all the balls and starting from scratch to let it load up the gumball machine also make sure you test the trough switches with balls in the correct sequence and in position not just by pressing them down
 
  • Like
Reactions: Vimtoman

stumblor

Site Supporter
Sep 16, 2018
2,173
2,433
113
London · Davey Price
stumblor-pinball.square.site
Alias
Davey Price
Is TZ opto or microswitch trough?

I was having double ball shooter Lane issues on creech due to the microswitches rubbing on the side wall of the trough bracket. Because they didn't turn off immediately due to the friction, the game assumed the balls hadn't moved and tried again. I've also read that the lever mech in position 1 that adds the ball to the lane, if unaligned properly, can cause problems if its hitting one of the switch arms. Bending it slightly can help, although this wasn't my issue.
 
  • Like
Reactions: DRD
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Have you got the correct amount of balls in it
Maybe worth going in to the menu and removing all the balls and starting from scratch to let it load up the gumball machine also make sure you test the trough switches with balls in the correct sequence and in position not just by pressing them down
Hi Chris

Yes, I have the correct amount of balls. I did the test, removing all balls and then reloading, including the Gumball machine. I've also tested the switches with balls not just by pressing them down manually. The strange thing is, it happens ONLY as long as ball 1 is locked. When no ball or two balls are locked everything works just fine.
 

James

Site Supporter
Dec 29, 2017
4,622
2,977
113
Norwich
Alias
James
You are 100% sure this can only be replcated with a ball locked. Does it explicitly kick out two balls? It could be just a simple magnetised ball issue, presenting in this manner, but it sounds like you have tested with rigour to confirm it isn't.
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Is TZ opto or microswitch trough?

I was having double ball shooter Lane issues on creech due to the microswitches rubbing on the side wall of the trough bracket. Because they didn't turn off immediately due to the friction, the game assumed the balls hadn't moved and tried again. I've also read that the lever mech in position 1 that adds the ball to the lane, if unaligned properly, can cause problems if its hitting one of the switch arms. Bending it slightly can help, although this wasn't my issue.
Hi
It's microswitch, they seem to work fine. This error only occurs when ball 1 is locked. If not ball or two balls are locked, everything works just fine, so I assume it's not related to the microswitches in the trough bracket. But I still have no idea what the could be the connection of ball 1 being locked and then two balls shoot to the shooter land
 
  • Like
Reactions: aaronhicksuk
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
You are 100% sure this can only be replcated with a ball locked. Does it explicitly kick out two balls? It could be just a simple magnetised ball issue, presenting in this manner, but it sounds like you have tested with rigour to confirm it isn't.
Hi James
Yes, as far as my tests go, I can reproduce the error only when 1 ball is locked. What I did not check is magnetised ball, but this seems unlikely to me, as I can always reproduce the error with one ball locked, and which balls are in the trough bracket is absolutely random
 

pinballmania

Site Supporter
Jul 21, 2011
2,136
1,462
113
In switch edge test take a picture of the switch matrix with three balls in the trough and none locked. Then place one of the three trough balls into the lock and take another picture of the switch matrix. Post them here.
 

M4carp

Site Supporter
Jan 12, 2019
2,476
2,175
113
Pembrokeshire
Alias
David
Maybe try resetting the ribbon cables, fixes some unexplainable faults.
Trough opto board fault can shoot out extra balls but if it only happens when ball 1 locked maybe it only happens with 2 balls in the trough?
Normlly only 3 balls in trough I think or 2 with one in play.
 

stumblor

Site Supporter
Sep 16, 2018
2,173
2,433
113
London · Davey Price
stumblor-pinball.square.site
Alias
Davey Price
Hi
It's microswitch, they seem to work fine. This error only occurs when ball 1 is locked. If not ball or two balls are locked, everything works just fine, so I assume it's not related to the microswitches in the trough bracket. But I still have no idea what the could be the connection of ball 1 being locked and then two balls shoot to the shooter land

It could still be the trough, in that the issue only occurs on the switch that became the 'last ball' when one ball is locked (ie one less ball in the trough)
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
In switch edge test take a picture of the switch matrix with three balls in the trough and none locked. Then place one of the three trough balls into the lock and take another picture of the switch matrix. Post them here.
The look switch seems to work correctly, also in play, when I lock 1st Ball, it is displayed: Ball 1 locked
 

Attachments

  • 2BallsinTrough_1_Ball_Locked.jpg
    2BallsinTrough_1_Ball_Locked.jpg
    110.1 KB · Views: 46
  • 3BallsinTrough_NO_Ball_Locked.jpg
    3BallsinTrough_NO_Ball_Locked.jpg
    102.7 KB · Views: 45

pinballmania

Site Supporter
Jul 21, 2011
2,136
1,462
113
Looks like it is not seeing the ball at lower lock with a ball resting there. Switch May work with finger but it’s not showing closed in your static picture.

Also the state of the switch next to it has changed. Does switch state 98 change when you press lock lower switch 88?
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
It could still be the trough, in that the issue only occurs on the switch that became the 'last ball' when one ball is locked (ie one less ball in the trough)
Good point, thank you, so I have to check this 'last ball' switch again
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Looks like it is not seeing the ball at lower lock with a ball resting there. Switch May work with finger but it’s not showing closed in your static picture.

Also the state of the switch next to it has changed. Does switch state 98 change when you press lock lower switch 88?
Am I reading the matrix wrong? To me it seems correct. Lock lower, and Left Trogh, I've marked them in the picture. Or I slipped in the column?
 

Attachments

  • 2BallsinTrough_1_Ball_Locked.jpg
    2BallsinTrough_1_Ball_Locked.jpg
    118 KB · Views: 16
  • 3BallsinTrough_NO_Ball_Locked.jpg
    3BallsinTrough_NO_Ball_Locked.jpg
    111.3 KB · Views: 16

pinballmania

Site Supporter
Jul 21, 2011
2,136
1,462
113
Yes. You’re right. I’m reading it wrong again. It’s because I’m flipping through things on my phone and getting columns confused.
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Isn’t this error cause by that proximity sensor opto down near the trough? I’m sure I had this prob in mine
How can I test this? For me it seems the it works fine. I have a new (6 month old) Proximity Dedector Board installed. As the original one did not detect the powerball 100% reliable.
And why does this problem only arise when ball 1 is locked? If the proximity sensor was the problem, wouldn't this behavior occur more often and not only when ball 1 is locked?
I've re-calibrated the proximity sensor and it detects the powerball perfectly
 

RudeDogg1

Site Supporter
Dec 27, 2012
8,226
1,784
113
42
Barnstaple, Devon
How can I test this? For me it seems the it works fine. I have a new (6 month old) Proximity Dedector Board installed. As the original one did not detect the powerball 100% reliable.
And why does this problem only arise when ball 1 is locked? If the proximity sensor was the problem, wouldn't this behavior occur more often and not only when ball 1 is locked?
I've re-calibrated the proximity sensor and it detects the powerball perfectly

Oh ignore me I forgot that sensor is for the powerball
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Have you checked the diodes are all the correct way on the switches ?
The pinball used to work for half a year now, never had this two ball problem, had a few other problems , which I've fixed all, e.g. replace flipper coil etc. but never this two ball behavior. So since I've never touched the switches, I assume yes they are all correct.
 
  • Like
Reactions: Pick Holder

Pick Holder

Site Supporter
Jul 18, 2016
2,708
1,991
113
51
Bournville, Birmingham.
The pinball used to work for half a year now, never had this two ball problem, had a few other problems , which I've fixed all, e.g. replace flipper coil etc. but never this two ball behavior. So since I've never touched the switches, I assume yes they are all correct.
Ahhh, never assume Sir !

Also do not test the switches by rolling your finger over, best to put a ball in the lock physically.
 

DRD

Site Supporter
Oct 26, 2014
4,354
3,246
113
Newark
Could it be a physical thing rather than electronic?

Is the shooter kick out solenoid firing once or twice when it incorrectly ejects 2 balls ?

If only 2 balls are in the ball trough (as one is locked), there is less weight pressing down on the shooter kick out solenoid

Might the problem be a misaligned kick out mech ? Loose mech ?

Or, the middle ball trough microswitch might be slow to release- this happens if the screws securing it are installed too tightly
 
Last edited:
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Ahhh, never assume Sir !

Also do not test the switches by rolling your finger over, best to put a ball in the lock physically.
I know assume nothing :) . Yes I've tested the switches with balls as well. The screenshots in previous posts were made using the balls, having a real ball in the lock and in the ball trough
 
Last edited:
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Could it be a physical thing rather than electronic?

Is the shooter kick out solenoid firing once or twice when it incorrectly ejects 2 balls ?

If only 2 balls are in the ball trough (as one is locked), there is less weight pressing down on the shooter kick out solenoid

Might the problem be a misaligned kick out mech ? Loose mech ?

Or, the middle ball trough microswitch might be slow to release- this happens if the screws securing it are installed too tightly
>Is the shooter kick out solenoid firing once or twice when it incorrectly ejects 2 balls ?
By firing, are you referring to mechanically kicking out two balls? If you referring to that, then yes: It is really firing twice and the pause in between is around 1 second.
>Might the problem be a misaligned kick out mech ? Loose mech ?
I can check that, last time I had a look seemed ok, but I can double check
>Or, the middle ball trough microswitch might be slow to release- this happens if the screws securing it are installed too tightly
I can check that as well. Last time I checked them manually all the trough microswitches seemed to mechanically work the same