Twilight Zone problem: EVERY ball detected as Powerball

MadNat

Site Supporter
May 11, 2019
583
605
93
Warwickshire UK
What is the significance of the powerball in TZ? What does it actually do?

For me it’s a really good part of the game. Instant multiball if you put it into the gumball. The bloody thing flies about at a fair rate of knots also... so if you can control it - you can quickly progress certain parts of the game (and your score).

So actually an important element to the overall game play in my opinion - I’d be annoyed if it wasn’t working on my machine. Clock on the other hand - not a big deal if that’s not working.
 
  • Like
Reactions: Paul R Owen
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
I've had a good think about this. I'm no expert - but my thoughts are that you've proved that the eddy is working properly (unless there is an intermittant failure?).

Have you tested all switches? It is at least worth checking every switch on the same row and column as switch 26


Other than a fake switch result - very long shot but maybe its a timing issue between the ball releasing and the position 1 slot being filled with the next ball takes some time? Perhaps that is fooling the TZ into thinking it just sent out a powerball? Does the ball eject fire more than once to get a ball into the shooter lane?

Perhaps post a video of the exact process of ball being loaded into the shooter lane and seeing the powerball announcement couldhelp other suggestions?

A bit of a head scratcher to be honest.
I've uploaded a video: https://drive.google.com/file/d/1XuUXEu3pBb7KOjmO_161UrqJDe4ECeAK/view?usp=sharing
Yes, unfortunately a head scratcher - hopefully I will not loose all my hair :)
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
I don't suppose you have "No Powerball" set to YES in the settings, do you? That would simulate a powerball for every second ball regardless of what it was, or whether the gumball machine was actually working or not.
Thank you, yes you suppose correct:, "No Powerball" is set to No.
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
If it’s announcing powerball every time a ball pops out of the trough you would think it’s trough/eddy issue. Odd as usual on this pin.
Unfortunately it does not seem to be an trough/eddy issue based on the tests performed so far
 
  • Like
Reactions: M4carp

Moonraker

Site Supporter
Aug 18, 2011
4,889
2,287
113
Salisbury
www.specialwhenlit.co.uk
Thank you, yes you suppose correct:, "No Powerball" is set to No.

I have known menu settings to be ignored before now, the most famous are no ball save and no extra balls settings being selected for the world championships. Come the final, one of the games selected provided a ball save to give a huge advantage over the other finalist.

Try setting "No Powerball" to Yes, play a few games then switch off and back on again then try setting "No Powerball" to No and play a game to see if there's any change.
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
I don't suppose you have "No Powerball" set to YES in the settings, do you? That would simulate a powerball for every second ball regardless of what it was, or whether the gumball machine was actually working or not.
Yes, You suppose correct I have the setting "No Powerball" set to No
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
If it’s announcing powerball every time a ball pops out of the trough you would think it’s trough/eddy issue. Odd as usual on this pin.
Yes, but unfortunately according to my tests so far the trough/eddy switches work fine
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
I have known menu settings to be ignored before now, the most famous are no ball save and no extra balls settings being selected for the world championships. Come the final, one of the games selected provided a ball save to give a huge advantage over the other finalist.

Try setting "No Powerball" to Yes, play a few games then switch off and back on again then try setting "No Powerball" to No and play a game to see if there's any change.
Very good idea, thank you. I performed the setting change test from No Powerball to Yes and then back to no again, unfortunately still the same behaviour, every ball is detected as powerball.
Except, If I play such a wrongly detected powerball in e.g. the Camera, so it has to pass the other proximity switch 57 - powerball play is off ..., so slot proximity switch 57 is working as tested before but trough proximity switch 26 is working as well so I really do not understand this behavior at all.
Probably I am already lost forever in the twilight zone - LOL
 
Last edited:
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Do you mean swap the board? Unfortunately, I would not know how to do that, the two boards differ in geometry and dimension.
 

Attachments

  • TroughProximityBoard_Switch26.jpg
    TroughProximityBoard_Switch26.jpg
    135.3 KB · Views: 12
  • SlotProximitiyBoard_Switch57.jpg
    SlotProximitiyBoard_Switch57.jpg
    89.1 KB · Views: 12

MadNat

Site Supporter
May 11, 2019
583
605
93
Warwickshire UK
If it would help you - I’d be happy to fit your eddy board to my TZ and see if I get the same problem as you.

That way we could 100% rule in/out that component causing your problem.

Pm me for address details if you think that would be helpful.

Mike
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
If it would help you - I’d be happy to fit your eddy board to my TZ and see if I get the same problem as you.

That way we could 100% rule in/out that component causing your problem.

Pm me for address details if you think that would be helpful.

Mike
Hi Mike
Thank you for your very generous offer. I will now first contact the manufacturer of my board and ask what other test possibilities there are. If that does not bring anything I will be very happy to come back to your offer. Thanks again.
 

Durzel

Site Supporter
Oct 1, 2017
2,007
834
113
Bath, UK
How have you tested the eddy board? Does it only close the switch on Switch Edge test when there is an actual powerball in the trough or when any ball is present?

I would say just because the LED is lit in the presence of a metal ball (or not), doesn’t necessarily mean that the correct signal is coming from the eddy board to the CPU.

What happens if you disconnect the eddy board?

If the game is clearing the false powerball status when it passes the subway eddy sensor, everything points to the tough one being faulty in some way.
 

MartinY

Site Supporter
Nov 18, 2017
1,294
767
113
Hampshire
When the powerball (and normal pinball) was in the trough, switch 26 reported correctly. He also tested the LED on/off when a normal ball passed over the Eddy....
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
When the powerball (and normal pinball) was in the trough, switch 26 reported correctly. He also tested the LED on/off when a normal ball passed over the Eddy....
Yes, I've also tested the LED: it is on with a Metall ball in the Right Trough, off with a Ceramic Ball in the Right Trough
 

Durzel

Site Supporter
Oct 1, 2017
2,007
834
113
Bath, UK
It wouldn't hurt to disconnect the eddy board completely and see what happens then.

I used to get "26 Check Trough Proximity" if my eddy board was acting up (who doesn't), but not every ball being detected as a Powerball. I can't see how else the game would determine that. It seems to me that there is either an internal fault in the CPU/software, which seems unlikely, the eddy board is not quite right, or "No Powerball" is set to "YES" (although that should still mean its only every other ball that's treated as a PB ).
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
It wouldn't hurt to disconnect the eddy board completely and see what happens then.

I used to get "26 Check Trough Proximity" if my eddy board was acting up (who doesn't), but not every ball being detected as a Powerball. I can't see how else the game would determine that. It seems to me that there is either an internal fault in the CPU/software, which seems unlikely, the eddy board is not quite right, or "No Powerball" is set to "YES" (although that should still mean its only every other ball that's treated as a PB).
I've disconnected the eddy board - then no powerball at all anymore.
But I get the Message check lef, ul, right and ur flipper EOS.
After I reconnected the eddy board I still got check left and ul flipper eos. I got those messages sometimes and sometimes not. the EOS switch is fine, I've checked, so could there be a wiring side effect?
No Powerball is set to "No"
 
Last edited:

Pick Holder

Site Supporter
Jul 18, 2016
2,708
1,991
113
51
Bournville, Birmingham.
Sounds like you have a wiring issue. The flipper EOS switches go onto the flip tropic board and not the cpu board.

Sounds like you may have a data issue.
I don’t think your sensor board is at fault.

check every switch in test and make sure a single switch does not trigger other switches. You could have a knackered diode or backward diode.
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Sounds like you have a wiring issue. The flipper EOS switches go onto the flip tropic board and not the cpu board.

Sounds like you may have a data issue.
I don’t think your sensor board is at fault.

check every switch in test and make sure a single switch does not trigger other switches. You could have a knackered diode or backward diode.
Is your assumption that the fliptronic board has an issue?
according to my understanding, the eos lie outside the switch matrix and are evaluated by the cpu, or am I wrong?
How should I test every switch? Search every switch on the playfield and activate it manually?
 
Last edited:
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
It seems now that the Coil-Board has an issue. The Coil ferrite surface is damaged, although the assembly was made correctly in the largest possible distance.
 

Attachments

  • CoilBoard2.jpg
    CoilBoard2.jpg
    60.3 KB · Views: 15
  • CoilBoard1.jpg
    CoilBoard1.jpg
    54.3 KB · Views: 15
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
I will get a new coil. I suppose this will solve the problem. I'll update as soon as I have replaced the coil.
MANY thanks to you all, who spent their time for support This is very appreciated.
Without your great help I would not have been able to find the root cause of the problem.
 

M4carp

Site Supporter
Jan 12, 2019
2,476
2,175
113
Pembrokeshire
Alias
David
My coil looks worse than that and still works. If you are getting the signal from metal balls to the switch matrix then it should be working.
Just played mine expecting something to go wrong, only took me 18 months to fix all the issues😊
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
My coil looks worse than that and still works. If you are getting the signal from metal balls to the switch matrix then it should be working.
Just played mine expecting something to go wrong, only took me 18 months to fix all the issues😊
In static test modes it gets the signal, but nor during gameplay, which is, you are right odd. Please see also movie: https://drive.google.com/file/d/1KCuzjwffovyraS4_8Okw8Q4iuWl44GY7/view?usp=sharing
The test play was with the following Ball order: 1, Metal, 2. Ceramic, 3. Metal, 4. Metal

So I hope the replacment will solve the issue.
Yes I know I've already fixed so many things :)
 
  • Like
Reactions: M4carp
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
When you know it, everything is simple...
Thanks to your tips, I made new holes in the plastic mounting of the coil board and mounted it as far away from the Right Trough as possible - and lo and behold, everything works fine again!
Thank you all for your help in solving this problem!
 
OP
W

wbk

Registered
Dec 27, 2020
48
9
8
Aargau
Alias
wbk
Mine has taken some work to get 100% working - but it is well worth it. A great game with so much going on. No regrets here.
I fully agree it's worth the effort TWZ is one of the best Pins ever!
 
  • Like
Reactions: M4carp