Williams firepower issue

Simon barker

Registered
Apr 2, 2018
39
14
8
Nottinghaminovermy
Hi all.i have a friends firepower by William's to look at,this is not my thing as im more for dmd type.anyway the pin went dead,no displays or switched lights.all you get is generally illumination.there is no sign of heat or component damage and all fuses check good out of circuit.any ideas please,I dont have a manual so cant check if needed voltages are present.
 

AlanJ

Site Supporter
Dec 27, 2017
3,079
3,007
113
Leeds, West Yorkshire
Alias
I am me
So mpu not booting. what is status of the 2 leds on the mpu board when you switch on?

The mpu needs 12v and 5v from the power board to boot. you could check those two voltages are present.
 

The seeker

Site Supporter
Oct 13, 2015
970
471
63
Northumberland
search for williams system 3-9 games iirc they are all similar and yo right get more luck in terms of solutions, could be a fuse but most likely capacitors full board repair would set you back around 350 and new boards similar but it could be something simple,ps arv knows best on this stuff so follow his sage advice
 

andy

Site Supporter
Jul 21, 2011
705
336
63
Bristol
Simon, if it turns out your MPU is toast I do have a Rottendog MPU327 combo MPU/driver board available that I bought 18 months ago and only used while the boards in my Alien Poker was off for repair, so has been sat in my spares box for the last 17 months!

Looking back at the invoice from Pinball Palace I see I paid £284.40 inc postage for it, yours for £175 inc postage.

Definitely do all @Arv has said in terms of diagnosis and I’d also say professional repair of original non-corroded boards is preferable to a Rottendog repo, but if you do end up needing a replacement let me know.

Andy
 

Chilpin

Registered
Apr 22, 2020
24
1
3
Cardiff
When you turn the game on and the seven segment display just stay in zero without any blink or flash, that means that the CPU either isn't booting, isn't resetting, or has locked up attempting to boot. Common problems are bad CPU sockets or a bad inter-board interconnect board. If it blink one time and then stay in zero, that means there is a rom problem or socket problem.
The diagnostic code in the seven segment display only is realiable only if the game is booting properly.. and this game without any cpu controlled light or displays seems to not be booting. So you cant trust in that code. BTW. the numer one means that the IC13 RAM 2114 fault or IC20 ROM bad.

You can check the voltages in the cpu here:
  • TP1 = +12 VDC unreg. (upper left)
  • TP2 = NMI, +5 VDC (center bottom) It should read 0 VDC when diagnostic switch SW1 is pressed.
  • TP3 = Memory Protect (left center) +5 VDC when interlock closed, 0 VDC when interlock open.
  • TP4 = Blanking (left bottom, just to right of batteries) +5 VDC normal operation, 0 VDC blanking (when first turned on for about 1 second).
  • TP7 = CMOS RAM B+ (just under TP3) +4.3 VDC when power on, +3.9 VDC when power is off. If this is low, your batteries are low.
  • TP8 = RESET (right bottom) 0 VDC for first second that power is on, +5 VDC after that.
  • TP9 = +5 VDC (lower left, just at the upper right corner of batteries)
 
OP
S

Simon barker

Registered
Apr 2, 2018
39
14
8
Nottinghaminovermy
Sorry for delay,been busy working.anyway,all said voltages at test points are correct.no batteries fitted at moment.the guy said it just died while playing.its in very good cond.owned last 12 years and little use.