NGG Switch Issue

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
Hi Guys, had a issue turn up on NGG not come across this sort of issue before. basically there are loads of phantom switch activations. first one is when you turn it on, the jet popper fires about 5 times then it stops. when the start button is pushed it starts a 4 player game then after that its all very random, but mostly the jet popper firing a lot of the time. when the ball goes in the putting green scoop nothing happens until ball search. the more you play and start more modes it usually activates the tilt. I went In to switch edge test to try and locate what switch is activating the jet popper. the jet popper is linked in to the trough opto switch line. narrowed it down to ball 3 opto activates the jet popper. cleaned and reheated solder on both boards (all solder connections) and the jet popper opto also. still the same issue. could this just be a dodgy trough Opto board? can that cause issues with all the other random switches? Want to see if I am on the right lines before I order new trough opto boards, incase I am looking completely in the wrong place.
cheers guys, any help would be much appreciated
 

AlanJ

Beta Tester
Dec 27, 2017
1,833
1,586
113
Leeds, West Yorkshire
Alias
I am me
Are there any other switches ON in the switch test that shouldnt be? I had an issue similar that looked like a trough opto but it turned out a standup target switch was shorted on and had shorted out it's diode - and this caused one of the trough optos to behave really oddly.
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
Oh really? I will have another look tonight after work. I did replace a stand up actually. It played fine for a a bit though. I only mean a few games.


Sent from my iPhone using Tapatalk
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
Are there any other switches ON in the switch test that shouldnt be? I had an issue similar that looked like a trough opto but it turned out a standup target switch was shorted on and had shorted out it's diode - and this caused one of the trough optos to behave really oddly.
Will have to figure out how many opto’s there are. As obviously always show on in switch edge test. Then can see if there’s a rogue switch that’s on


Sent from my iPhone using Tapatalk
 

Pick Holder

Beta Tester
Jul 18, 2016
2,096
1,424
113
51
Bournville, Birmingham.
Diode issue as Chris B said, or have you possibly an old fashioned short or a blob of solder jammed in somewhere.
Check the manual and see if the switches that trigger are on the same row/column and then check those.
For the small cost. Replace all the diodes and check polarity.
 
  • Like
Reactions: Carl85
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
If you have replaced a target or switch recently I would look at that first I suspect diode on wrong way or wired incorrectly
Thanks, yes I was wondering that. It’s on a different line but guess any switch having a problem can cause all to play up. It did play a few games fine before playing up. But to be honest it’s the only thing I have touched within the switch matrix. Let’s hope it’s that simple. I will try and look at the old switch (if the bin hasn’t gone out ) to make sure the diode line is the same way. Pretty sure I wired it to the same legs but you never know, it was late


Sent from my iPhone using Tapatalk
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
Diode issue as Chris B said, or have you possibly an old fashioned short or a blob of solder jammed in somewhere.
Check the manual and see if the switches that trigger are on the same row/column and then check those.
For the small cost. Replace all the diodes and check polarity.
Thanks, the switch I replaced was on a different column but guess can still cause issues. All the trough are in the same column and the jet popper is the last one in that column. Will try and make sure the diode line is the same as the old switch. Will check solder too as I did some soldering on the pop bumper light sockets so maybe so solder did drop somewhere


Sent from my iPhone using Tapatalk
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85

Top blue one is the one that activates the bottom blue (jet popper).
Red one is the target that was replaced


Sent from my iPhone using Tapatalk
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
Slam tilt shorted on the door ?
Not sure to be honest. Will have to check when I get home. At work at the moment so won’t be in until after 9pm, I didn’t notice anything when I was looking around but I wasn’t really looking for that to be honest.


Sent from my iPhone using Tapatalk
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
This was the target replaced. All seems to be the same.




Sent from my iPhone using Tapatalk
 
OP
Carl85

Carl85

Site Supporter
Jan 20, 2020
253
143
43
35
Kent uk
Alias
Carl85
Just an update guys. Turns out some idiot wired a switch in wrong. All sorted now.


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: astyy