Hobbit small LCD not working

JAG555

Site Supporter
Jul 23, 2017
670
465
63
UK
I assume you have checked both connectors (in and out)?

I think it’s HDMI if memory serves.
 

Pick Holder

Site Supporter
Jul 18, 2016
1,370
819
113
Midlands
JJP run off the internal video card, and they also have an external card in a PCI slot. If I was you take off the cover to expose the PC and reseat the card.
Check all your connections.

POWER OFF FIRST!

If it doesnt come back on - then use a VGA / DVI or HDMI cable into a computer monitor to check the signal.

Also the screen is fed with 12v power. Be worth checking that.
 
OP
IOXLEY

IOXLEY

Registered
Jun 14, 2016
57
26
18
BILLERICAY, ESSEX
Ok excellent guys
Thank you i will
It’s VGA and undid and re did the cable but made no difference. Will now check the rest of the things
 
  • Like
Reactions: JAG555

JAG555

Site Supporter
Jul 23, 2017
670
465
63
UK
You will need a multi-meter and check you have 12v coming out.

Do you have a PC Monitor with a VGA in?
 

Neil McRae

Site Supporter
Jun 5, 2016
8,139
5,234
113
Surrey
playpinball.uk
Alias
Neil McRae
Does the screen power up? If it’s not the cable or PC . JJP use a cheap rubbish screen that has a AV selection option - like on your TV - VGA, HDMI 1, HDMI 2 etc etc. sadly though the bit of hardware that you need to do the selection doesn’t come with the pin - so if you figure out it’s that ping me and I can loan you the device that lets you do the selection.
 
  • Like
Reactions: JAG555 and M4carp

JAG555

Site Supporter
Jul 23, 2017
670
465
63
UK
Keep us posted. I have a VGA Monitor I can run over, you are only 5 minutes from me.
 
OP
IOXLEY

IOXLEY

Registered
Jun 14, 2016
57
26
18
BILLERICAY, ESSEX
Hi guys
Well cable checked this morning and can confirm it’s not the cable.
So either power issue or screen/board.
What should I do next?
 
OP
IOXLEY

IOXLEY

Registered
Jun 14, 2016
57
26
18
BILLERICAY, ESSEX
Hi guys
So I plugged in a new vga and the screen worked.
so i guess now it’s either the screen itself or no power.
Chris b can you help ?
Thanks
Ian
 

Godzilla

Site Supporter
Sep 12, 2019
41
32
18
Exeter
I would test the power to the book LCD first Ian to eliminate it, I have found on my Hobbit (with use) connectors can work loose, I had issues with the door buttons and start lamp all related to a simple push connector. Your intermittent description matches my faults, working one minute then completely dead.

It looks like you could maybe get a reading at the connector itself to the screen, just be careful with meter probes or you’ll accidentally short things out and likely pop fuses.

As mentioned above be careful with the lid off, perhaps check related connections first using the manuals (J14 for example is the external connector see pic) with power off just to ensure all are seated properly.
 

Attachments

JAG555

Site Supporter
Jul 23, 2017
670
465
63
UK
Ok I’ve ordered a multi meter from amazon and will be coming tomorrow. Was £20, I take it anyone will work. Doesn’t need special adapters to do this does it?
Yeah, that should do it.

I am on in Wickford if you need anything.

Let us know how you get on.